LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Home Forums Tutorials Articles Register
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > Solaris / OpenSolaris
User Name
Password
Solaris / OpenSolaris This forum is for the discussion of Solaris, OpenSolaris, OpenIndiana, and illumos.
General Sun, SunOS and Sparc related questions also go here. Any Solaris fork or distribution is welcome.

Notices


Reply
  Search this Thread
Old 08-23-2004, 12:42 AM   #1
subaruwrx
Member
 
Registered: Mar 2004
Distribution: Ubuntu Feisty
Posts: 641

Rep: Reputation: 30
How to configure network with solaris?


Can't find in any of the gui program and not very familiar with solaris commands.
 
Old 08-23-2004, 01:39 AM   #2
jev-bird
Member
 
Registered: Jul 2004
Location: USofA
Distribution: Whatever runs accordingly.
Posts: 200

Rep: Reputation: 30
ifconfig should do it. Much more simpler to use dhcp. For instance if driver for your nic is rf0 do this from a terminal as root:

Code:
/sbin/ifconfig rf0 dhcp
That's assumed that the drivers for your nic are already loaded into your kernel. If they are not then you will have to install the driver, plumb it and maybe do some other stuff. The main thing is to find the correct driver for your nic. What kind of card is it?
 
Old 08-23-2004, 01:57 AM   #3
subaruwrx
Member
 
Registered: Mar 2004
Distribution: Ubuntu Feisty
Posts: 641

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by jev-bird
ifconfig should do it. Much more simpler to use dhcp. For instance if driver for your nic is rf0 do this from a terminal as root:

Code:
/sbin/ifconfig rf0 dhcp
That's assumed that the drivers for your nic are already loaded into your kernel. If they are not then you will have to install the driver, plumb it and maybe do some other stuff. The main thing is to find the correct driver for your nic. What kind of card is it?
I not sure if the drivers are already loaded. How do I check?

Anyway, ifconfig rf0 returns "No such interface"
 
Old 08-23-2004, 02:22 AM   #4
ppuru
Senior Member
 
Registered: Mar 2003
Location: Beautiful BC
Distribution: RedHat & clones, Slackware, SuSE, OpenBSD
Posts: 1,791

Rep: Reputation: 50
you may need to ifconfig plumb rf0 before you actually go ahead and set the ip, etc.
 
Old 08-23-2004, 02:29 AM   #5
subaruwrx
Member
 
Registered: Mar 2004
Distribution: Ubuntu Feisty
Posts: 641

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by ppuru
you may need to ifconfig plumb rf0 before you actually go ahead and set the ip, etc.
It said bad address.

Anyway I think my nic driver is not installed? Tried installing the driver, sheesh.. I doesn't have the "make" program installed as well
 
Old 08-23-2004, 03:43 AM   #6
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 13,174
Blog Entries: 1

Rep: Reputation: 2040Reputation: 2040Reputation: 2040Reputation: 2040Reputation: 2040Reputation: 2040Reputation: 2040Reputation: 2040Reputation: 2040Reputation: 2040Reputation: 2040
Try a prtconf -v to see if it lists any ethernet devices. If it does, note the name of the interface (hme, dmfe, rf or whatever) and then do:
ifconfig <interface+number i.e. hme0> IP netsmask xxx.xxx.xxx.xxx up.
Or better yet, to have your network configured from the beginning do a sys-unconfig.
 
Old 08-23-2004, 04:41 AM   #7
subaruwrx
Member
 
Registered: Mar 2004
Distribution: Ubuntu Feisty
Posts: 641

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by bathory
Try a prtconf -v to see if it lists any ethernet devices. If it does, note the name of the interface (hme, dmfe, rf or whatever) and then do:
ifconfig <interface+number i.e. hme0> IP netsmask xxx.xxx.xxx.xxx up.
Or better yet, to have your network configured from the beginning do a sys-unconfig.
I just installed the driver, not sure if its working.I use "prtconf -pv". My NIC is DLink/Real Tek RTL8139.

Code:
        Node 0x1a7908
            assigned-addresses:  81005010.00000000.0000c800.00000000.00000100.82
005014.00000000.dfffff00.00000000.00000100
            class-code:  00020000
            compatible: 'pci1186,1300' + 'pci1186,1300' + 'pci1186,1300' + 'pcic
lass,020000'
            device-id:  00001300
            devsel-speed:  00000001
            fast-back-to-back:
            interrupts:  00000001
            max-latency:  00000040
            min-grant:  00000020
            model:  'PCI: 1186,1300 - class: Ethernet controller'
            name:  'pci1186,1300'
            power-consumption:  00000001.00000001
            reg:  00005000.00000000.00000000.00000000.00000000.01005010.00000000
.00000000.00000000.00000100.02005014.00000000.00000000.00000000.00000100
            revision-id:  00000010
            slot:  00000002
            subsystem-id:  00001300
            subsystem-vendor-id:  00001186
            unit-address:  'a'
            vendor-id:  00001186
Then I modify the /etc/drivers_alias to change rtls "pci1188,1301" to rtls "pci1186,1301". The driver added 3 lines to the file.

Code:
rtls "pci1186,1301"
rtls "pci10ec,8139"
rtls "pci1113,1211"
Did a ifconfig -a, it only have lo0. Tried eth0, rh0, all reply with "No such interface"

2) Another problem I encountered, I don't have the "make" program installed, any idea how can I install it from the solaris cd?

Last edited by subaruwrx; 08-23-2004 at 05:24 AM.
 
Old 08-23-2004, 05:40 AM   #8
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris 11.4, Oracle Linux, Mint, Debian/WSL
Posts: 9,789

Rep: Reputation: 492Reputation: 492Reputation: 492Reputation: 492Reputation: 492
Make is usually at /usr/ccs/bin/make, it is installed when you do a full installation or a developer one.
If your software is demanding the gnu make, because of some of its extensions, you can also install it from varous freeware sites.

Concerning your network card, from the logs it looks like its name is rtls, so you need to do a:

ifconfig rtls0 plumb

to enable it, before any configuration can occur.
 
Old 08-23-2004, 05:40 AM   #9
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 13,174
Blog Entries: 1

Rep: Reputation: 2040Reputation: 2040Reputation: 2040Reputation: 2040Reputation: 2040Reputation: 2040Reputation: 2040Reputation: 2040Reputation: 2040Reputation: 2040Reputation: 2040
Then try ifconfig rtls0 plumb, ifconfig rtls0 IP netsmask xxx.xxx.xxx.xxx up
To add a package try: pkgadd -d /cdrom/<Package name>
But it's better to download the package from http://www.sunfreeware.com/ and do the pkgadd at the dir you've downloaded it.
 
Old 08-23-2004, 05:54 AM   #10
subaruwrx
Member
 
Registered: Mar 2004
Distribution: Ubuntu Feisty
Posts: 641

Original Poster
Rep: Reputation: 30
I tried rtls0, rtls1, rtls, all returned with "No such file or directory".
 
Old 08-23-2004, 06:56 AM   #11
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris 11.4, Oracle Linux, Mint, Debian/WSL
Posts: 9,789

Rep: Reputation: 492Reputation: 492Reputation: 492Reputation: 492Reputation: 492
try: devfsadm -v
 
Old 08-23-2004, 08:43 PM   #12
subaruwrx
Member
 
Registered: Mar 2004
Distribution: Ubuntu Feisty
Posts: 641

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by jlliagre
try: devfsadm -v
Done. Nothing came out.
 
Old 08-24-2004, 01:38 AM   #13
subaruwrx
Member
 
Registered: Mar 2004
Distribution: Ubuntu Feisty
Posts: 641

Original Poster
Rep: Reputation: 30
Ok I reinstalled solaris and reinstall the driver. Got this error.

cp rtls //kernel/drv/rtls
+ chmod 755 //kernel/drv/rtls
+ chown root:sys //kernel/drv/rtls
+ grep ^rtls\> /etc/name_to_major
+ add_drv -v -i "pci1186,1301" "pci10ec,8139" "pci1113,1211" rtls
exit status = 0
devfsadm: driver failed to attach: rtls
exit status = 11
Warning: Driver (rtls) successfully added to system but failed to attach
Driver (rtls) installed.
+ exit 0

I got my driver from http://www.realtek.com.tw/downloads/...eyword=solaris

There are also some information in the readme file in the driver folder that tells me to create the /etc/hostname.rtls0" file and modify some other related files to make my networking environments working well.

What information do I need to type in the /etc/hostname.rtls0 file and what are these "modify some other related files"?

Thanks in advanced.

Last edited by subaruwrx; 08-24-2004 at 02:25 AM.
 
Old 08-24-2004, 04:03 AM   #14
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 13,174
Blog Entries: 1

Rep: Reputation: 2040Reputation: 2040Reputation: 2040Reputation: 2040Reputation: 2040Reputation: 2040Reputation: 2040Reputation: 2040Reputation: 2040Reputation: 2040Reputation: 2040
In /etc/hostname.rtls0 you write the name of your host, but since you must change a lot of other files by hand it's better to use sys-unconfig to reconfigure your system.
 
Old 08-24-2004, 04:08 AM   #15
subaruwrx
Member
 
Registered: Mar 2004
Distribution: Ubuntu Feisty
Posts: 641

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by bathory
In /etc/hostname.rtls0 you write the name of your host, but since you must change a lot of other files by hand it's better to use sys-unconfig to reconfigure your system.
So, what do I do next?
 
  


Reply



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Network Printer on Solaris 8 Pimple Solaris / OpenSolaris 9 08-26-2015 01:16 PM
Network on solaris A-fil Solaris / OpenSolaris 15 11-19-2005 10:06 PM
how to configure my network on slackware 10.0 so i can access a windows network salviadud Linux - Newbie 2 02-11-2005 01:19 PM
How to I configure gcc on Solaris ehsan Solaris / OpenSolaris 5 01-08-2003 12:18 PM
How to configure a Network everywhere fast network card under Linux Mandrake 7.2 margo256 Linux - Newbie 1 03-12-2001 10:45 AM

LinuxQuestions.org > Forums > Other *NIX Forums > Solaris / OpenSolaris

All times are GMT -5. The time now is 09:25 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration