LinuxQuestions.org
Visit Jeremy's Blog.
Home Forums Tutorials Articles Register
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > Solaris / OpenSolaris
User Name
Password
Solaris / OpenSolaris This forum is for the discussion of Solaris, OpenSolaris, OpenIndiana, and illumos.
General Sun, SunOS and Sparc related questions also go here. Any Solaris fork or distribution is welcome.

Notices


Reply
  Search this Thread
Old 03-06-2008, 08:40 AM   #1
czezz
Member
 
Registered: Nov 2004
Distribution: Slackware/Solaris
Posts: 931

Rep: Reputation: 44
SARC 32 or 64 bit ?


How can I be sure is my SPARC is 32 or 64 bit ?

This is one of my machines Sun Fire V100:

Code:
bash-3.00# prtdiag
System Configuration:  Sun Microsystems  sun4u Sun Fire V100 (UltraSPARC-IIe 648MHz)
System clock frequency: 100 MHz
Memory size: 1024 Megabytes

========================= CPUs =========================

                    Run   Ecache   CPU    CPU
Brd  CPU   Module   MHz     MB    Impl.   Mask
---  ---  -------  -----  ------  ------  ----
 0     0     0      648     0.5   13       3.3


========================= IO Cards =========================

     Bus#  Freq
Brd  Type  MHz   Slot  Name                              Model
---  ----  ----  ----  --------------------------------  ----------------------
 0   PCI-0  33     0   dma-isadma
 0   PCI-0  33     0   rtc-m5819                         m5819
 0   PCI-0  33     0   power-acpi-power
 0   PCI-0  33     0   SUNW,lomh
 0   PCI-0  33     0   serial-su16550
 0   PCI-0  33     0   serial-su16550
 0   PCI-0  33     0   flashprom                         SUNW,258-7883
 0   PCI-0  33     0   i2c-i2c-smbus
 0   PCI-0  33     0   ppm-SUNW,smbus-ppm
 0   PCI-0  33     0   beep-SUNW,smbus-beep
 0   PCI-0  33     0   fan-control-SUNW,smbus-fan-contr+


No failures found in System
===========================
Is there any better way to check that ?
 
Old 03-06-2008, 09:22 AM   #2
scoban
Member
 
Registered: Nov 2004
Location: Turkey
Distribution: Slackware
Posts: 145

Rep: Reputation: 16
Code:
/usr/bin/isainfo -kv
 
Old 03-06-2008, 09:46 AM   #3
1jnike
Member
 
Registered: Jan 2006
Location: UK
Distribution: Fedora,Mandriva,Debian,Suse,Solaris
Posts: 135

Rep: Reputation: 17
Hi czezz,

Ensure the OBP (open boot prompt) is up to the latest version, to find out what the current OBP is you can run the following:

1. At OBP, use the '.version' command. The firmware versions
displayed should be:

ok .version
Firmware CORE Release 1.0.18 created 2002/5/23 18:22
Release 4.0 Version 18 created 2002/05/23 18:22
cPOST version 1.0.18 created 2002/5/23
CORE 1.0.18 2002/05/23 18:22
ok

2. When running Unix, use the prtconf(1M) command. The version
displayed should be:

# prtconf -V
OBP 4.0.18 2002/05/23 18:22
OR

3. # prtdiag -v

(the absolute path is /usr/plat*/`uname -i`/sbin)

To obtain the latest version check out the sun.com web site.

I hope this is of help

Jnike
 
Old 03-07-2008, 07:57 AM   #4
Dox Systems - Brian
Member
 
Registered: Nov 2006
Posts: 344

Rep: Reputation: 31
If it's an "UltraSPARC", it's 64-bit.
 
Old 03-07-2008, 05:59 PM   #5
javier.e.menendez
Member
 
Registered: Jan 2006
Posts: 168

Rep: Reputation: 30
Not to be a pain but the last answer is actually incorrect/misleading.

Not ultra-sparcs run 64 bit necessarily. I had an ultra 1 and a 2 that were running 32 bits. I had to change the jumper to support and run 64 bit.

Of course, solaris 10 does not run 32 bit on the sparc anymore. You can run 32 on x86. But that is a different story.
 
Old 03-07-2008, 07:37 PM   #6
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris 11.4, Oracle Linux, Mint, Debian/WSL
Posts: 9,789

Rep: Reputation: 492Reputation: 492Reputation: 492Reputation: 492Reputation: 492
sun4u architecture (UltraSPARC/SPARC64) supports both 32 bit and 64 bit code. Solaris 10 is only released with a 64 bit kernel on SPARC but can still run 32 bit applications for obvious compatibility reasons.
 
Old 03-20-2008, 11:38 PM   #7
prad77
Member
 
Registered: Mar 2008
Posts: 101

Rep: Reputation: 15
To determine what kind of binaries your Solaris machine can run, try the following:

eden:/home/cph: isainfo -v
64-bit sparcv9 applications
32-bit sparc applications

You can see that this Solaris machine is capable of running 32-bit as well as 64-bit applications. If isainfo fails, running a 64-bit application on your Sun will generally not be possible, unless of course isainfo is not in your path or has not been installed. You can also use the uname command to glean more information:

eden:/home/cph: uname -a
SunOS eden 5.8 Generic_108528-05 sun4u sparc SUNW,Ultra-5_10

lagrange:/usr/users/cph: uname -a
SunOS lagrange 5.5.1 Generic_103640-29 sun4u sparc SUNW,Ultra-1


SunOS/Solaris versions map to the following:
SunOS SOLARIS
5.3 2.3
5.4 2.4
5.5 2.5
5.5.1 2.5.1
5.6 2.6
5.7 or greater is 64-bit compliant 2.7 or greater is 64-bit compliant

While all UltraSparc processors are capable of 64-bit computing, the OS release level may be the limiting factor. In the above excerpt, 'eden' (SunOS 5.8) is a fully compliant 64-bit platform, and 'lagrange' (SunOS 5.5.1) is a 64-bit UltraSparc limited to 32-bit computing.

Fedora Development

Last edited by prad77; 04-17-2008 at 03:20 AM.
 
  


Reply



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
64 bit cpu-64 bit Ubuntu-are there 32 bit app issues? sofasurfer Ubuntu 7 04-09-2014 02:02 PM
Triple Boot Suse 10.3 32 bit, suse alpha 11.0 64 bit and Windows XP (32 Bit) 1kyle SUSE / openSUSE 1 02-28-2008 10:25 AM
LXer: Install Xen 3.1 Solaris domU (64 bit) under CentOS 5 dom0 (64 bit) LXer Syndicated Linux News 0 09-21-2007 12:00 AM
no KDE in Kubuntu 6.10 64-bit(ATI X800 GTO 256 bit DDr3) exul182 Linux - Hardware 2 01-04-2007 02:47 PM
32 bit or 64 bit install - is 32 bit easier for a newbie? dms05 Linux - Newbie 3 05-19-2006 03:05 PM

LinuxQuestions.org > Forums > Other *NIX Forums > Solaris / OpenSolaris

All times are GMT -5. The time now is 07:14 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration