LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Solaris / OpenSolaris (https://www.linuxquestions.org/questions/solaris-opensolaris-20/)
-   -   Solaris Software RAID (https://www.linuxquestions.org/questions/solaris-opensolaris-20/solaris-software-raid-612079/)

0.o 01-08-2008 03:52 PM

Solaris Software RAID
 
Hello,


I currently am in the position that i need to setup a Solaris server to use on our network (our being where i work). Unfortunately i am not terribly familiar with Solaris and how it functions. So, this brings me here.
I am currently in the process of trying to set up mirrors of two of the disks. There are four physical disks in the server. I want to mirror the first to the second and third to the fourth. Now, i have setup six metadbs in total. Two on each of the non-system disks. Now this is where i am getting lost. What's my next step? How do i mirror the currently active system disk? Do i have to mirror each slice independently? Any help would be greatly appreciated.

custangro 01-08-2008 03:59 PM

What version of Solaris are you using? To find out do this...

Code:

cat /etc/release
For Solaris 10 11.06 and newer you can use ZFS...it's pretty simple to implement...


Code:

zpool create <nameofpool1> <disk1> mirror <disk2>
zpool create <nameofpool2> <disk3> mirror <disk4>

There are other ways to configure what you mentioned using ZFS...this is the easiest...

-C

0.o 01-08-2008 05:17 PM

What's the best and most stable way of doing it? This server will be under lots of stress and needs to be able to withstand lots of torture. The way it is implemented currently (with a much older server) is with meta devices.

custangro 01-08-2008 05:34 PM

Performing tests at my Job; ZFS is faster than meta devices...There is some overhead involved (but you had that anyway with meta devices :)) But it's minor.

Our primary Web server (which we do most of our business on) is in the high 90s in idle time. zpool iostat shows little "disk trashing" (or in this case pool thrashing :)); But we are running on T2000 servers...so it depends on your hardware (if you get a chance check out the Sun SPARC Enterprise T5220 Server...I like to get my hands on that :D)

-C

0.o 01-08-2008 05:45 PM

This will be running on a Netra V440 with 4 584GB 15K SCSI disks; four ultrasparc processors; and 8gb of memory.

The middle one:

http://shop.sun.com/is-bin/INTERSHOP..._US-SunCatalog

javier.e.menendez 01-13-2008 04:12 PM

A couple of comments:

Based on the original email, you said to mirror the first with the second disk. If that is the boot disk, you CAN'T use zfs and you have to use either solaris volume manager or veritas volume manager.

Also, with zfs, the syntax looked wrong. It should be zpool create mypool mirror first_disk second_disk (not first_disk mirror second_disk).

With svm, you need state database replicas which you create with the following command:

metadb -afc 3 c0t0d0s3 (example here of course. 3 copies in one slice in this example; put a few more on the other drives if you can).

To mirror a file system (let's say /export/home on slice 7):

metainit -f d0 1 1 c0t0d0s7
metainit d1 1 1 c0t1d0s7
metainit -f d2 -m d0; umount /export/home; mount /dev/md/dsk/d2 /export/home (edit /etc/vfstab)
metattach d2 d1
metastat d2

Do the same for the others. Root, /usr and var can't be unmounted so it will require a reboot. Also look at the man page for metaroot (updates /etc/vfstab and /etc/system for you for the / file system.

custangro 01-13-2008 05:14 PM

Quote:

Originally Posted by javier.e.menendez (Post 3021285)
Also, with zfs, the syntax looked wrong. It should be zpool create mypool mirror first_disk second_disk (not first_disk mirror second_disk).

*sigh* you unix people and the syntax...

Fist off you're right; the command was wrong (slightly...but still wrong nonetheless)

Why do we geeks feel the need to "show up" other people. We cannot memorize EVERY COMMAND IN EXISTANCE...that's why the man pages are for...it's sad when people are annal like that....

Next time iI'll put a disclaimer saying "I'm not at work right now so there is no way to test my commmands but the theory is all there..."

Also I thought it was common knowledge that the boot drive cannot be a ZFS filesystem...so I assumed that I did not have to mentioned that.

If you want slow performance...use metadbs; also you shouldn't use metadbs on your boot drive because you will "thrash" your boot drive...which is bad...Good luck...I'm unsubscribing to this thread now...


-C

crisostomo_enrico 01-14-2008 03:08 AM

Quote:

*sigh* you unix people and the syntax...

Fist off you're right; the command was wrong (slightly...but still wrong nonetheless)

Why do we geeks feel the need to "show up" other people. We cannot memorize EVERY COMMAND IN EXISTANCE...that's why the man pages are for...it's sad when people are annal like that....
Sorry for commenting this but there's nothing wrong in pointing out wrong syntax: it's something that could help *others* looking LQ for help, rather than pointing out that you have written something wrong, which is human and comprehensible.

If someone studying mathematics looks for help, and you help them saying that what you're saying is not correct but... there's a book for it, why should I look for help? ;) Maybe I'm stuck with something I cannot see.

UltraSoul 01-15-2008 01:51 AM

Hi,

PS: you can refer the following site from docs.sun.com about how to create SVM mirror volume for root filesystem.

http://docs.sun.com/app/docs/doc/816-4520/frkdb?a=view

javier.e.menendez 01-15-2008 05:21 AM

Ouch, talk about touchy...

I did not mean to show up anybody here, I was just trying to help the person that opened this thread.

Also, if I was trying to show up anybody, I would have mentioned that you can also use zfs on 06/06 as well, not only
on 11/06. The only things missing on 06/06 that appeared on 11/06 were raidz2 which is not what we were talking about
or the concept of the spare (also new in 11/06).

So let's chill out, it is about helping people "custangro". LOL.

javier.e.menendez 01-15-2008 05:25 AM

I forgot as well...

What do you mean about not putting the the metadbs on the boot drive and trashing the disks? If the user has 4 disks, he should put the replicas on all 4 drives for high availability and redundancy. Even if you have two disks and you want to mirror the boot disk, you put the state databases on both disks. There is a parameter to put on /etc/system that allows
the system to boot up even if you lose one disk (meaning you come back with only 50% of the replicas). You can google that
if you want.

good luck,

J.


All times are GMT -5. The time now is 08:18 PM.